如果安全外壳(SSH)协议是在最近的网络技术背景下设计的,它会是什么样子?这是来自UCLouvain的Olivier Bonaventure和我在撰写最新研究文章时提出的问题。SSH协议提供了一种在不信任的网络上远程安全访问计算机的方式。目前,SSH是访问Unix-based主机的最流行的方式。建立在未加密的TCP协议之上,SSH提出了自己的机制来建立安全通道和执行用户身份验证。在最近几年,我们看到传输协议设计的重大进展,新的协议如QUIC提出了快速和安全的TCP替代方案。到2023年底,我们重新审视了SSH协议,考虑了QUIC(RFC 9000)、TLS 1.3(RFC 8446)和HTTP/3(RFC 9114)等最近的协议,距离其最初的设计几乎30年。结果是一个提供增强功能集而不妥协的协议,相比SSHv2。
SSH3的设计
SSH3使用QUIC和TLS1.3来建立安全通道,并使用HTTP授权(RFC 9114,RFC 9110)机制来执行用户身份验证。SSH3允许以下改进:更快的会话建立、HTTP身份验证方法(如OAuth 2.0(RFC 6749)和OpenID Connect(OIDC))以及传统的SSH用户身份验证、对端口扫描攻击的鲁棒性——SSH3服务器可以对其他互联网用户不可见、UDP端口转发(除了传统的TCP端口转发)以及QUIC协议允许的所有功能,包括连接迁移和多路径连接。
HTTP/3的机制
HTTP/3提供了一种新的传输协议,基于QUIC,提供了更快的连接建立和更好的多路径连接支持。HTTP/3还提供了更好的安全性,使用TLS 1.3来加密数据。这些机制使得SSH3能够提供更快、更安全的远程访问。
SSH3的实现
SSH3的实现计划已经提交给SIGCOMM计算机通信审查杂志,代码也已在GitHub上发布。仅仅几天,项目就获得了1000多个星标,成为我们研究实验室增长最快的项目。SSH3的实现提供了一个候选的新一代SSH协议,是否会成为SSH的第三个版本或一个独立的协议,将来会在互联网工程任务组(IETF)讨论后决定。
对于运维和网络工程师来说,SSH3提供了更快、更安全的远程访问方式,能够更好地支持现代网络环境和应用场景。SSH3的实现也为未来SSH协议的发展提供了一个新的方向,值得关注和研究。
原文: APNIC Blog(2024-02-02)|编译自 APNIC Blog,事实以原文为准。
来源:APNIC Blog